Conflict with Give plugin

#1
When I install the Give plugin, it causes the following error in the Javascript console:

---

Uncaught TypeError: $ is not a function
at HTMLDocument.<anonymous> (http://netnpeople.org/netnpeople/wp-con ... =4.7:103:5)
at i (http://netnpeople.org/netnpeople/wp-adm ... .7:2:27449)
at Object.fireWith [as resolveWith] (http://netnpeople.org/netnpeople/wp-adm ... .7:2:28213)
at Function.ready (http://netnpeople.org/netnpeople/wp-adm ... .7:2:30006)
at HTMLDocument.K (http://netnpeople.org/netnpeople/wp-adm ... .7:2:30368)

---

The result is that AJAX seems to stop working. If I click "Quick Edit" from the All Posts page, for instance, nothing happens. It affects a great many things. If I deactivate the Give plugin, everything works again. I've already contacted the developer of the Give plugin, and he tried it out and says it needs to be fixed on GT3Themes' end.

Re: Conflict with Give plugin

#2
I fixed it myself.

I edited wp-content/themes/yellowproject/core/page-builder/js/pb.js so that all the code in the file was wrapped in the following:

var jq=jQuery.noConflict();
jq(document).ready(function(){
[ORIGINAL CODE IN THE FILE]
});

Now my admin area works again, and it doesn't seem to have broken Page Builder, knock on wood.
Post Reply

Return to “YellowProject Multipurpose Retina WP Theme”

Who is online

Users browsing this forum: No registered users and 1 guest